createRotationAroundAxisIndex MethodStatic
Returns a rotation of specified angle around an axis
createRotationAroundAxisIndex(axisIndex: AxisIndex, angle: Angle, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
axisIndex | AxisIndex | index of axis (AxisIndex.X, AxisIndex.Y, AxisIndex.Z) kept fixed by the rotation. |
angle | Angle | angle of rotation |
result | Matrix3d | optional result matrix. * Math details of 3d rotation matrices derivation can be found at docs/learning/geometry/Angle.md |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 724
Last Updated: 20 June, 2023