createRigidViewAxesZTowardsEye MethodStatic
create a rigid coordinate frame column z parallel to (x,y,z) and column x in the xy plane.
- column z points from origin to x,y,z
- column x is perpendicular and in the xy plane
- column y is perpendicular to both. It is the "up" vector on the view plane.
- Multiplying a world vector times the transpose of this matrix transforms into the view xy
- Multiplying the matrix times the an in-view vector transforms the vector to world.
createRigidViewAxesZTowardsEye(x: number, y: number, z: number, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
x | number | eye x coordinate |
y | number | eye y coordinate |
z | number | eye z coordinate |
result | Matrix3d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 1221
Last Updated: 20 June, 2023