createRigidFromMatrix3d MethodStatic
Create a new orthogonal matrix (perpendicular columns, unit length, transpose is inverse).
- Columns are taken from the source Matrix3d in order indicated by the axis order.
- Mirroring in the matrix is removed.
createRigidFromMatrix3d(source: Matrix3d, axisOrder: AxisOrder = AxisOrder.XYZ, result?: Matrix3d): undefined | Matrix3d
Parameter | Type | Description |
---|---|---|
source | Matrix3d | |
axisOrder | AxisOrder | |
result | Matrix3d |
Returns - undefined | Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 2525
Last Updated: 20 June, 2023