createPartialRotationVectorToVector MethodStatic
Return a matrix that rotates a fraction of the angular sweep from vectorA to vectorB.
createPartialRotationVectorToVector(vectorA: Vector3d, fraction: number, vectorB: Vector3d, result?: Matrix3d): undefined | Matrix3d
Parameter | Type | Description |
---|---|---|
vectorA | Vector3d | initial vector position |
fraction | number | fractional rotation. 1.0 is "all the way" |
vectorB | Vector3d | final vector position |
result | Matrix3d | optional result matrix. |
Returns - undefined | Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 1070
Last Updated: 20 June, 2023