createFromQuaternion MethodStatic
create a matrix from a quaternion. WARNING: There is frequent confusion over whether a "from quaternion" matrix is organized by rows and columns. WARNING: If you find that the matrix seems to rotate by the opposite angle expect it, transpose it.
createFromQuaternion(quat: Point4d): Matrix3d
Parameter | Type | Description |
---|---|---|
quat | Point4d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 2547
Last Updated: 20 June, 2023