createDirectionalScale MethodStatic
Create a matrix that scales along a specified direction.
- The scale factor can be negative.
- A scale of -1.0 (negative one) is a mirror across the plane perpendicular to the vector.
createDirectionalScale(direction: Vector3d, scale: number, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
direction | Vector3d | |
scale | number | |
result | Matrix3d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 1532
Last Updated: 20 June, 2023