createCapture MethodStatic
Create a Matrix3d with caller-supplied coefficients and optional inverse coefficients.
- The inputs are captured into (i.e., owned by) the new Matrix3d.
- The caller is responsible for validity of the inverse coefficients.
createCapture(coffs: Float64Array, inverseCoffs?: Float64Array): Matrix3d
Parameter | Type | Description |
---|---|---|
coffs | Float64Array | (required) array of 9 coefficients. |
inverseCoffs | Float64Array | (optional) array of 9 coefficients. |
Returns - Matrix3d
a Matrix3d populated by a coffs array.
Defined in
- geometry3d/Matrix3d.ts Line 428
Last Updated: 20 June, 2023