axisOrderCrossProductsInPlace Method
Form cross products among columns in axisOrder. For axis order ABC,
- form cross product of column A and B, store in C
- form cross product of column C and A, store in B. This means that in the final matrix:
- column A is strictly parallel to original column A
- column B is linear combination of only original A and B
- column C is perpendicular to A and B of both the original and final.
- original column C does not participate in the result.
axisOrderCrossProductsInPlace(axisOrder: AxisOrder): void
Parameter | Type | Description |
---|---|---|
axisOrder | AxisOrder |
Returns - void
Defined in
- geometry3d/Matrix3d.ts Line 2083
Last Updated: 20 June, 2023