addScaledOuterProductInPlace Method
add scaled values from an outer product.
- The scaled outer product is a "rank 1" matrix.
- This is useful in constructing mirrors and directional scales.
addScaledOuterProductInPlace(vectorU: Vector3d, vectorV: Vector3d, scale: number): void
Parameter | Type | Description |
---|---|---|
vectorU | Vector3d | |
vectorV | Vector3d | |
scale | number | scale factor to apply to the added values. |
Returns - void
Defined in
- geometry3d/Matrix3d.ts Line 2333
Last Updated: 20 June, 2023