tripleProduct MethodStatic
Returns Returns the triple product of 3 vectors provided as x,y,z number sequences.
- The triple product is the determinant of the 3x3 matrix with the 9 numbers (3 vectors placed in 3 rows).
- The triple product is positive if the 3 vectors form a right handed coordinate system.
- The triple product is negative if the 3 vectors form a left handed coordinate system.
- Treating the 9 numbers as 3 vectors U, V, W, any of these formulas gives the same result:
- U dot (V cross W)
- V dot (W cross U)
- W dot (U cross V)
- (-U dot (W cross V)) -- (note the negative -- reversing cross product order changes the sign)
- (-V dot (U cross W)) -- (note the negative -- reversing cross product order changes the sign)
- (-W dot (V cross U)) -- (note the negative -- reversing cross product order changes the sign)
- the triple product is 6 times the (signed) volume of the tetrahedron with the three vectors as edges from a common vertex.
tripleProduct(ux: number, uy: number, uz: number, vx: number, vy: number, vz: number, wx: number, wy: number, wz: number): number
Parameter | Type | Description |
---|---|---|
ux | number | |
uy | number | |
uz | number | |
vx | number | |
vy | number | |
vz | number | |
wx | number | |
wy | number | |
wz | number |
Returns - number
Defined in
- Geometry.ts Line 533
Last Updated: 20 June, 2023