solveTrigForm MethodStatic
return the 0, 1, or 2 pairs of (c,s) values that solve {constCoff + cosCoff * c + sinCoff * s = 0} with the constraint {cc+ss = 1}
solveTrigForm(constCoff: number, cosCoff: number, sinCoff: number): undefined | Vector2d[]
Parameter | Type | Description |
---|---|---|
constCoff | number | |
cosCoff | number | |
sinCoff | number |
Returns - undefined | Vector2d[]
Defined in
- Geometry.ts Line 730
Last Updated: 20 June, 2023