getValidatedFrame Method
Try to assemble the data into a non-singular transform.
- If allowLeftHanded is false, vector0 and vector1 determine a right handed coordinate system.
- if allowLeftHanded is true, the z vector of the right handed system can be flipped to agree with vector2 direction.
getValidatedFrame(allowLeftHanded: boolean = false): undefined | Transform
Parameter | Type | Description |
---|---|---|
allowLeftHanded | boolean |
Returns - undefined | Transform
Defined in
- geometry3d/FrameBuilder.ts Line 65
Last Updated: 20 June, 2023