createXYBox MethodStatic
Create a convex clip plane set that clips to x0 <= x <= x1
and y0 <= y <= y1
.
- Note that there is no test for the usual ordering
x0 <= x1
ory0 <= y1
.- if the usual ordering is violated, the convex set is an empty set.
createXYBox(x0: number, y0: number, x1: number, y1: number, result?: ConvexClipPlaneSet): ConvexClipPlaneSet
Parameter | Type | Description |
---|---|---|
x0 | number | |
y0 | number | |
x1 | number | |
y1 | number | |
result | ConvexClipPlaneSet |
Returns - ConvexClipPlaneSet
Defined in
- clipping/ConvexClipPlaneSet.ts Line 157
Last Updated: 20 June, 2023