clipInsidePushOutside Method
Clip a convex polygon to (a single) inside part and (possibly many) outside parts.
clipInsidePushOutside(xyz: GrowableXYZArray, outsideFragments: undefined | GrowableXYZArray[], arrayCache: ): undefined | GrowableXYZArray
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | input polygon. |
outsideFragments | undefined | GrowableXYZArray[] | an array to receive (via push, with no preliminary clear) outside fragments |
arrayCache | cache for work arrays. |
Returns - undefined | GrowableXYZArray
the surviving inside part (if any)
Defined in
- clipping/ConvexClipPlaneSet.ts Line 456
Last Updated: 20 June, 2023