clipConvexPolygonInPlace Method
Clip a polygon to the inside of the convex set.
- Results with 2 or fewer points are ignored.
- Other than ensuring capacity in the arrays, there are no object allocations during execution of this function.
clipConvexPolygonInPlace(xyz: GrowableXYZArray, work: GrowableXYZArray, tolerance: number = Geometry.smallMetricDistance): void
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | input points. |
work | GrowableXYZArray | work buffer |
tolerance | number | tolerance for "on plane" decision. |
Returns - void
Defined in
- clipping/ConvexClipPlaneSet.ts Line 443
Last Updated: 20 June, 2023