appendPolygonClip Method
Implement appendPolygonClip, as defined in interface PolygonClipper. /**
appendPolygonClip(xyz: GrowableXYZArray, insideFragments: GrowableXYZArray[], outsideFragments: GrowableXYZArray[], arrayCache: ): void
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | input polygon. This is not changed. |
insideFragments | GrowableXYZArray[] | Array to receive "inside" fragments. Each fragment is a GrowableXYZArray grabbed from the cache. This is NOT cleared. |
outsideFragments | GrowableXYZArray[] | Array to receive "outside" fragments. Each fragment is a GrowableXYZArray grabbed from the cache. This is NOT cleared. |
arrayCache | cache for reusable GrowableXYZArray. |
Returns - void
Defined in
- clipping/ConvexClipPlaneSet.ts Line 735
Last Updated: 20 June, 2023