multiplyPlanesByMatrix4d Method
Multiply all ClipPlanes DPoint4d by matrix.
multiplyPlanesByMatrix4d(matrix: Matrix4d, invert: boolean = true, transpose: boolean = true): boolean
Parameter | Type | Description |
---|---|---|
matrix | Matrix4d | matrix to apply. |
invert | boolean | if true, use in verse of the matrix. |
transpose | boolean | if true, use the transpose of the matrix (or inverse, per invert parameter) * Note that if matrixA is applied to all of space, the matrix to send to this method to get a corresponding effect on the plane is the inverse transpose of matrixA * Callers that will apply the same matrix to many planes should pre-invert the matrix for efficiency. * Both params default to true to get the full effect of transforming space. |
Returns - boolean
Defined in
- clipping/ClipPrimitive.ts Line 230
Last Updated: 20 June, 2023