ClipPlaneProps Interface
Wire format describing a ClipPlane. If either ClipPlaneProps.normal or ClipPlaneProps.dist are omitted, defaults to a normal of Vector3d.unitZ and a distance of zero.
Properties
Name | Type | Description | |
---|---|---|---|
dist | undefined | number | The plane's distance from the origin. | |
interior | undefined | boolean | Defaults to false . |
|
invisible | undefined | boolean | Defaults to false . |
|
normal | undefined | XYZProps | The plane's inward normal. |
Defined in
- clipping/ClipPlane.ts Line 33
Last Updated: 20 June, 2023