createNormalAndPointXYZXYZ MethodStatic
Create a ClipPlane
- "normal" (normalX, normalY, nz) is the inward normal of the plane.
- The given (normalX,normalY,normalZ)
- "point" is any point of the plane.
- The stored distance for the plane is the dot product of the point with the normal (i.e. treat the point's xyz as a vector from the origin.)
createNormalAndPointXYZXYZ(normalX: number, normalY: number, normalZ: number, originX: number, originY: number, originZ: number, invisible: boolean = false, interior: boolean = false, result?: ClipPlane): undefined | ClipPlane
Parameter | Type | Description |
---|---|---|
normalX | number | |
normalY | number | |
normalZ | number | |
originX | number | |
originY | number | |
originZ | number | |
invisible | boolean | |
interior | boolean | |
result | ClipPlane |
Returns - undefined | ClipPlane
Defined in
- clipping/ClipPlane.ts Line 155
Last Updated: 20 June, 2023