clipConvexPolygonInPlace Method
Clip a polygon to the inside or outside of the plane.
- Results with 2 or fewer points are ignored.
- Other than ensuring capacity in the arrays, there are no object allocations during execution of this function.
clipConvexPolygonInPlace(xyz: GrowableXYZArray, work: GrowableXYZArray, inside: boolean = true, tolerance: number = Geometry.smallMetricDistance): number
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | input points. |
work | GrowableXYZArray | work buffer |
inside | boolean | |
tolerance | number | tolerance for "on plane" decision. |
Returns - number
Defined in
- clipping/ClipPlane.ts Line 461
Last Updated: 20 June, 2023