setFromJSON Method
set this AngleSweep from various sources:
- if json is undefined, a full-circle sweep is returned.
- If json is an AngleSweep object, it is cloned
- If json is an array of 2 numbers, those numbers are start and end angles in degrees.
- If
json.degrees
is an array of 2 numbers, those numbers are start and end angles in degrees. - If
json.radians
is an array of 2 numbers, those numbers are start and end angles in radians. - Otherwise, a full-circle sweep is returned.
setFromJSON(json?: any): void
Parameter | Type | Description |
---|---|---|
json | any |
Returns - void
Defined in
- geometry3d/AngleSweep.ts Line 367
Last Updated: 20 June, 2023