radiansToSignedPeriodicFraction Method
return the fractionalized position of the given angle (as radian) computed with consideration of 2PI period and with consideration of angle sweep direction (CW or CCW).
- the start angle is at fraction 0
- the end angle is at fraction 1
- interior angles are between 0 and 1
- negative fraction for angles "before" the start angle
- fraction larger than one for angles "after" the end angle
- allows period shift
radiansToSignedPeriodicFraction(radians: number): number
Parameter | Type | Description |
---|---|---|
radians | number |
Returns - number
Defined in
- geometry3d/AngleSweep.ts Line 311
Last Updated: 20 June, 2023