radiansToPositivePeriodicFraction Method
return the fractionalized position of the given angle (as radians), computed with consideration of 2PI period.
- fraction is always positive
- the start angle is at fraction 0
- the end angle is at fraction 1
- interior angles are between 0 and 1
- all exterior angles are at fractions greater than 1
- allows period shift
radiansToPositivePeriodicFraction(radians: number, zeroSweepDefault: number = 0.0): number
Parameter | Type | Description |
---|---|---|
radians | number | |
zeroSweepDefault | number |
Returns - number
Defined in
- geometry3d/AngleSweep.ts Line 271
Last Updated: 20 June, 2023