appendSingleClipPrimitive Method
Modifies the insideIntervals array given in place. Note: curve given is passed by reference and stored.
appendSingleClipPrimitive(root: AlternatingCCTreeNode, curve: CurvePrimitive, insideIntervals: CurveLocationDetailPair[], _outsideIntervals: CurveLocationDetailPair[]): void
Parameter | Type | Description |
---|---|---|
root | AlternatingCCTreeNode | |
curve | CurvePrimitive | |
insideIntervals | CurveLocationDetailPair[] | |
_outsideIntervals | CurveLocationDetailPair[] |
Returns - void
Defined in
Last Updated: 20 June, 2023