BSplineWrapMode Enumeration
Enumeration of the possible ways of converting a "periodic" knot vector to an open knot vector.
None (0) ==> no wrap possible
OpenByAddingControlPoints (1) ==> wrapped by adding poles
OpenByRemovingKnots (2) ==> wrapped by deleting extreme knots.
Members
Name |
Value |
Description |
None |
0 |
No conversion to periodic |
OpenByAddingControlPoints |
1 |
Convert to periodic by removing control points. This is typical for closed bcurve constructed by control points with maximum continuity. * Knots stay the same in open and periodic form. * Periodic form omits {degree} control points. |
OpenByRemovingKnots |
2 |
Convert to periodic by adding special knots. This is typical of closed bcurve constructed as exact circular or elliptic arc * 2 knots on each end are omitted in open form * poles stay the same. |
Defined in
Last Updated:
20 June, 2023