createGrid MethodStatic
Create a bspline with given knots.
Two count conditions are recognized in each direction:
** If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping. ** If poleArray.length + order == knotArray.length + 2, the knots are in modern form.
createGrid(xyzwGrid: number[][][], weightStyle: WeightStyle, orderU: number, knotArrayU: number[], orderV: number, knotArrayV: number[]): undefined | BSplineSurface3dH
Parameter | Type | Description |
---|---|---|
xyzwGrid | number[][][] | |
weightStyle | WeightStyle | |
orderU | number | |
knotArrayU | number[] | |
orderV | number | |
knotArrayV | number[] |
Returns - undefined | BSplineSurface3dH
Defined in
- bspline/BSplineSurface.ts Line 875
Last Updated: 20 June, 2023