spanFractionsToBasisFunctions Method
Evaluate basis functions given
- choice of u or v
- span index
- local fraction within the span.
spanFractionsToBasisFunctions(select: UVSelect, spanIndex: number, spanFraction: number, f: Float64Array, df?: Float64Array): void
Parameter | Type | Description |
---|---|---|
select | UVSelect | |
spanIndex | number | |
spanFraction | number | |
f | Float64Array | |
df | Float64Array |
Returns - void
Defined in
- bspline/BSplineSurface.ts Line 333
Last Updated: 20 June, 2023