computeStrokeCountForOptions Method
Assess length and turn to determine a stroke count.
- this method is used by both BSplineCurve3d and BSplineCurve3dH.
- points are accessed via getPolePoint3d.
- Hence a zero-weight pole will be a problem
computeStrokeCountForOptions(options?: StrokeOptions): number
Parameter | Type | Description |
---|---|---|
options | StrokeOptions | stroke options structure. |
Returns - number
Defined in
- bspline/BezierCurveBase.ts Line 203
Last Updated: 20 June, 2023