crossProductIndexIndexXYAndZ Method
Return the cross product of the vectors from origin
to the point at indexA
and to targetB
crossProductIndexIndexXYAndZ(origin: number, indexA: number, targetB: Readonly<WritableXYAndZ>, result?: Vector3d): undefined | Vector3d
Parameter | Type | Description |
---|---|---|
origin | number | index of point within the array; origin of both vectors |
indexA | number | index of point within the array; target of the first vector |
targetB | Readonly<WritableXYAndZ> | target of second vector |
result | Vector3d | optional caller-allocated result to fill and return |
Returns - undefined | Vector3d
undefined if an index is out of bounds
Defined in
- geometry3d/IndexedXYZCollection.ts Line 147
Last Updated: 20 June, 2023