linearCombination Method
Compute the linear combination s of the indexed p_i and given scales s_i.
linearCombination(scales: number[], result?: Point2d | Vector2d): XY
Parameter | Type | Description |
---|---|---|
scales | number[] | array of scales. For best results, scales should have same length as the instance. |
result | Point2d | Vector2d | optional pre-allocated object to fill and return |
Returns - XY
s = sum(p_i * s_i), where i ranges from 0 to min(this.length, scales.length).
Defined in
- geometry3d/IndexedXYCollection.ts Line 106
Last Updated: 20 June, 2023