copyData MethodProtected

Copy data from source array. Does not reallocate or change active entry count.

copyData(source: number[] | Float64Array, sourceCount?: number, destOffset?: number): { count: number, offset: number }

Parameter Type Description
source number[] | Float64Array array to copy from
sourceCount number copy the first sourceCount entries; all entries if undefined
destOffset number copy to instance array starting at this index; zero if undefined

Returns - { count: number, offset: number }

count and offset of entries copied

Defined in

Last Updated: 20 June, 2023