setEyePoint Method
Change the location of the eyePoint for the camera in this view.
setEyePoint(pt: Readonly<WritableXYAndZ>): void
note This method is generally for internal use only. Moving the eyePoint arbitrarily can result in skewed or illegal perspectives. The most common method for user-level camera positioning is #lookAt.
Parameter | Type | Description |
---|---|---|
pt | Readonly<WritableXYAndZ> | The new eyepoint. |
Returns - void
Defined in
- core/frontend/src/ViewState.ts Line 2064
Last Updated: 20 June, 2023