moveCameraLocal Method
Move the camera relative to its current location by a distance in camera coordinates.
moveCameraLocal(distance: Vector3d): ViewStatus
Parameter | Type | Description |
---|---|---|
distance | Vector3d | to move camera. Length is in world units, direction relative to current camera orientation. |
Returns - ViewStatus
Status indicating whether the camera was successfully positioned. See values at ViewStatus for possible errors.
Defined in
- core/frontend/src/ViewState.ts Line 1899
Last Updated: 20 June, 2023