lookAt Method
Setup view state for either perspective or orthographic view.
lookAt(args: LookAtPerspectiveArgs | LookAtOrthoArgs | LookAtUsingLensAngle): ViewStatus
note If the aspect ratio of viewDelta does not match the aspect ratio of a Viewport into which this view is displayed, it will be adjusted when the Viewport is synchronized from this view.
Parameter | Type | Description |
---|---|---|
args | LookAtPerspectiveArgs | LookAtOrthoArgs | LookAtUsingLensAngle |
Returns - ViewStatus
A ViewStatus indicating whether the camera was successfully positioned.
Defined in
- core/frontend/src/ViewState.ts Line 1771
Last Updated: 20 June, 2023