setRotation MethodAbstract
Change the rotation of the view.
setRotation(viewRot: Matrix3d): void
note viewRot must be ortho-normal. For 2d views, only the rotation angle about the z axis is used.
Parameter | Type | Description |
---|---|---|
viewRot | Matrix3d |
Returns - void
Defined in
- core/frontend/src/ViewState.ts Line 503
Last Updated: 20 June, 2023