lookAtViewAlignedVolume Method
Look at a volume of space defined by a range in view local coordinates, keeping its current rotation.
lookAtViewAlignedVolume(volume: Range3d, aspect?: number, options?: MarginOptions & OnViewExtentsError): void
Parameter | Type | Description |
---|---|---|
volume | Range3d | The new volume, in view-aligned coordinates. The resulting view will show all of the volume. |
aspect | number | The X/Y aspect ratio of the view into which the result will be displayed. If the aspect ratio of the volume does not match aspect, the shorter axis is lengthened and the volume is centered. If aspect is undefined, no adjustment is made. |
options | MarginOptions & OnViewExtentsError | for providing MarginPercent and onExtentsError |
Returns - void
Defined in
- core/frontend/src/ViewState.ts Line 1026
Last Updated: 20 June, 2023