calculateFrustum Method
Calculate the world coordinate Frustum from the parameters of this ViewState.
calculateFrustum(result?: Frustum): undefined | Frustum
Parameter | Type | Description |
---|---|---|
result | Frustum | Optional Frustum to hold result. If undefined a new Frustum is created. |
Returns - undefined | Frustum
The 8-point Frustum with the corners of this ViewState, or undefined if the parameters are invalid.
Defined in
- core/frontend/src/ViewState.ts Line 691
Last Updated: 20 June, 2023