screenSpaceEffects
Accessor
An ordered list of names of screen-space post-processing effects to be applied to the image rendered by the Viewport. The effects are applied to the image in the order in which they appear in the list. Any names not corresponding to a registered effect are ignored. This may have no effect if the Viewport's RenderTarget does not support screen-space effects.
screenSpaceEffects: Iterable<string>
see RenderSystem.createScreenSpaceEffectBuilder to create and register new effects.
Returns - Iterable<string>
Setter
An ordered list of names of screen-space post-processing effects to be applied to the image rendered by the Viewport. The effects are applied to the image in the order in which they appear in the list. Any names not corresponding to a registered effect are ignored. This may have no effect if the Viewport's RenderTarget does not support screen-space effects.
screenSpaceEffects(effects: Iterable<string>): void
see RenderSystem.createScreenSpaceEffectBuilder to create and register new effects.
Parameter | Type | Description |
---|---|---|
effects | Iterable<string> |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 2734
Last Updated: 20 June, 2023