numReadyTiles
AccessorReadOnly
The number of tiles which were ready and met the desired level-of-detail for display in the view as of the most recently-drawn frame.
These tiles may not have been selected because some other (probably sibling) tiles were not ready for display.
This is a useful metric for determining how "complete" the view is - e.g., one indicator of progress toward view completion can be expressed as:
(numReadyTiles) / (numReadyTiles + numRequestedTiles)
numReadyTiles: number
see Viewport.numRequestedTiles
Returns - number
Defined in
- core/frontend/src/Viewport.ts Line 1618
Last Updated: 20 June, 2023