isSubCategoryVisible Method
Determine whether geometry belonging to a specific SubCategory is visible in this viewport, assuming the containing Category is displayed.
isSubCategoryVisible(id: string): boolean
note Because this function does not know the Id of the containing Category, it does not check if the Category is enabled for display. The caller should check that separately if he knows the Id of the Category.
Parameter | Type | Description |
---|---|---|
id | string | The Id of the subcategory |
Returns - boolean
true if the subcategory is visible in this viewport.
Defined in
- core/frontend/src/Viewport.ts Line 688
Last Updated: 20 June, 2023