getMapLayerScaleRangeVisibility Method
Beta
Return the map-layer scale range visibility for the provided map-layer index.
getMapLayerScaleRangeVisibility(index: number, isOverlay: boolean): MapTileTreeScaleRangeVisibility
see DisplayStyleState.mapLayerAtIndex.
Parameter | Type | Description |
---|---|---|
index | number | of the owning map layer. |
isOverlay | boolean | true if the map layer is overlay, otherwise layer is background |
Returns - MapTileTreeScaleRangeVisibility
Defined in
- core/frontend/src/Viewport.ts Line 805
Last Updated: 20 June, 2023