flashedId
Accessor
The Id of the currently-flashed object.
The "flashed" visual effect is typically applied to the object in the viewport currently under the mouse cursor, to indicate
it is ready to be interacted with by a tool. ToolAdmin is responsible for updating it when the mouse cursor moves.
The object is usually an Element but could also be a Model or pickable decoration produced by a Decorator.
The setter ignores any string that is not a well-formed Id64String. Passing Id64.invalid to the
setter is equivalent to passing undefined
- both mean "nothing is flashed".
flashedId: undefined | string
throws Error if an attempt is made to change this property from within an Viewport.onFlashedIdChanged event callback.
see Viewport.onFlashedIdChanged to be notified when the flashed object changes.
see Viewport.flashSettings to customize the visual effect.
Returns - undefined | string
Setter
The Id of the currently-flashed object.
The "flashed" visual effect is typically applied to the object in the viewport currently under the mouse cursor, to indicate
it is ready to be interacted with by a tool. ToolAdmin is responsible for updating it when the mouse cursor moves.
The object is usually an Element but could also be a Model or pickable decoration produced by a Decorator.
The setter ignores any string that is not a well-formed Id64String. Passing Id64.invalid to the
setter is equivalent to passing undefined
- both mean "nothing is flashed".
flashedId(id: undefined | string): void
throws Error if an attempt is made to change this property from within an Viewport.onFlashedIdChanged event callback.
see Viewport.onFlashedIdChanged to be notified when the flashed object changes.
see Viewport.flashSettings to customize the visual effect.
Parameter | Type | Description |
---|---|---|
id | undefined | string |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 1564
Last Updated: 20 June, 2023