antialiasSamples
Accessor
Sets the number of MSAA samples for this viewport. The number of samples is a power of two. Values of 1 or less indicates anti-aliasing should be disabled. Non-power-of-two values are rounded down to the nearest power of two. The maximum number of samples supported depends upon the client's graphics hardware capabilities. Higher values produce a higher-quality image but also may also reduce framerate.
antialiasSamples: number
see ViewManager.setAntialiasingAllViews to adjust the number of samples for all viewports.
Returns - number
Setter
Sets the number of MSAA samples for this viewport. The number of samples is a power of two. Values of 1 or less indicates anti-aliasing should be disabled. Non-power-of-two values are rounded down to the nearest power of two. The maximum number of samples supported depends upon the client's graphics hardware capabilities. Higher values produce a higher-quality image but also may also reduce framerate.
antialiasSamples(numSamples: number): void
see ViewManager.setAntialiasingAllViews to adjust the number of samples for all viewports.
Parameter | Type | Description |
---|---|---|
numSamples | number |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 620
Last Updated: 20 June, 2023