addViewedModels Method
Adds a set of models to the set of those currently displayed in this viewport.
addViewedModels(models: Id64Arg): Promise<void>
note This function only works if the viewport is viewing a SpatialViewState, otherwise it does nothing.
note If any of the requested models is not yet loaded this function will asynchronously load them before updating the set of displayed models.
Parameter | Type | Description |
---|---|---|
models | Id64Arg |
Returns - Promise<void>
Defined in
- core/frontend/src/Viewport.ts Line 911
Last Updated: 20 June, 2023