ViewCreator3dOptions Interface
Options for creating a ViewState3d via ViewCreator3d.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
allSubCategoriesVisible | undefined | boolean | Indicates that geometry belonging to every SubCategory should be visible within the view. | |
cameraOn | undefined | boolean | Turn the Camera on to produce a perspective view. | |
skyboxOn | undefined | boolean | Enables display of a SkyBox in the view. | |
standardViewId | undefined | StandardViewId | Orients the view to one of the standard view rotations. | |
useSeedView | undefined | boolean | Merge in props from a persistent "seed" view obtained from the iModel. | |
vpAspect | undefined | number | The desired aspect ratio of the Viewport in which the view is to be displayed. |
Defined in
Last Updated: 20 June, 2023