openToolTip Method
Open the toolTip window in this ScreenViewport with the supplied message and location. The tooltip will be a child of ScreenViewport.toolTipDiv.
openToolTip(message: string | HTMLElement, location?: Readonly<WritableXAndY>, options?: ToolTipOptions): void
note There is only one ToolTip window, so calling this method more than once will move the toolTip and show the second message.
Parameter | Type | Description |
---|---|---|
string | HTMLElement | The message to display | |
location | Readonly<WritableXAndY> | The position of the toolTip, in view coordinates. If undefined, use center of view. |
options | ToolTipOptions | the ToolTip options |
Returns - void
Defined in
- core/frontend/src/Viewport.ts Line 3042
Last Updated: 20 June, 2023