LookAtArgs Interface
Arguments to ViewState3d.lookAt for either a perspective or orthographic view
Properties
Name | Type | Description | |
---|---|---|---|
backDistance Readonly | undefined | number | The distance from the eyePoint to the back plane. | |
eyePoint Readonly | Readonly<WritableXYAndZ> | The new location of the camera/eye. | |
frontDistance Readonly | undefined | number | The distance from the eyePoint to the front plane. | |
newExtents Readonly | undefined | Readonly<WritableXAndY> | The new size (width and height) of the view rectangle on the focus plane centered on the targetPoint. | |
opts Readonly | undefined | OnViewExtentsError | Used for providing onExtentsError. | |
upVector Readonly | Vector3d | A vector that orients the camera's "up" (view y). |
Defined in
- core/frontend/src/ViewState.ts Line 92
Last Updated: 20 June, 2023