create MethodStatic
Create an animator to transition to the specified destination.
create(viewport: ScreenViewport, destination: GlobalLocation): Promise<undefined | GlobeAnimator>
Parameter | Type | Description |
---|---|---|
viewport | ScreenViewport | The viewport to animate. |
destination | GlobalLocation | The destination to travel to. |
Returns - Promise<undefined | GlobeAnimator>
An animator, or undefined if the viewport's iModel is not geolocated or its view is not 3d.
Defined in
- core/frontend/src/GlobeAnimator.ts Line 106
Last Updated: 20 June, 2023