changeMapSubLayerProps Method
Modify a subset of a sub-layer settings.
changeMapSubLayerProps(props: Partial<MapSubLayerProps>, subLayerId: SubLayerId, layerIndex: number, isOverlay: boolean): void
Parameter | Type | Description |
---|---|---|
props | Partial<MapSubLayerProps> | props JSON representation of the properties to change. Any properties not present will retain their current values. |
subLayerId | SubLayerId | Id of the sub-layer that should be modified. |
layerIndex | number | of the owning map layer. |
isOverlay | boolean | true if the map layer is overlay, otherwise layer is background |
Returns - void
Defined in
Last Updated: 20 June, 2023