changeMapLayerProps Method
Modify a subset of a map layer settings.
changeMapLayerProps(props: Partial<MapLayerProps>, index: number, isOverlay: boolean): void
Parameter | Type | Description |
---|---|---|
props | Partial<MapLayerProps> | props JSON representation of the properties to change. Any properties not present will retain their current values. |
index | number | where the layer should be inserted. |
isOverlay | boolean | true if layer is overlay, otherwise layer is background. Example that changes only the visibility of the first overlay map layer. ts<br> style.changeMapLayerProps({ visible: false }, 0, false);<br> |
Returns - void
Defined in
Last Updated: 20 June, 2023